jumpy_mouse_in_xen_on_qubes-os

Sat, 19 Sep 2015 12:35:45 EDT tim.
thelion@[REDACTED]

Hello,

I’ve just installed 9front-3487.66db43ef6cd1.iso in xen on Qubes-os. I am experiencing a jumpy mouse. I beleive that the problem is not with my xen configuration, as the same configuration works fine for reactos, haiku, debian. It also works fine within the installer for plan9 from bell labs(though after that version of plan9 is installed the mouse does not work at all.) Anyways, I’ll jump straight to the details:

As you can see in the screenshot, the mouse moves by long steps rather than fluidly. That file was generated with the command “cat /dev/mouse > mouse-file-unformated” and then reformatted with sed.

My plan9.ini is very boring:

bootfile=9pcf bootargs=local!/dev/sdC0/fscache mouseport=ps2 monitor=vesa vgasize=1024x768x16

Echoing various things to /dev/mousectl didn’t help. I tried everything liseted in the mouse man page, linear, accelerated, hwaccel on and off, res 0, 1,2,and 3. None seemd to have a positive effect.

http://plan9front.googlecode.com/issues/attachment?aid=1990000000&name=9front-jumpy-mouse.png


discussion:

Apr 8, 2014 #1
tereniao…@[REDACTED] What version of Xen? What is the host OS, and what version? I suggested using a non-vesa display, did you try this? Alternatively, did you try any Xen options to turn off the (extremely hacky) mouse synchronization? 9front barely has enough manpower to support real hardware. A member of our community with extensive sysadmin experience — he’s worked his way up to administer a supercomputer — says Xen stinks to high heaven, so why should we put time into this? You might get lucky here, someone may find he has the time and motivation to solve this, but given that drawterm is an effective workaround, I wouldn’t be surprised if other things take priority. If anyone does decide to work on this, I think our choices are either USB tablet support, (I know, USB stinks too,) or to find/make a display driver which Xen can provide and which has a hardware mouse cursor.

Apr 8, 2014 #2 tim.
thel…@[REDACTED] I get one of the /dev/realmode does not exist errors. I didn’t recompile anything though. https://groups.google.com/forum/#!msg/comp.os.plan9/YwDt1MVWKAo/YZwEoJihmWYJ

Apr 8, 2014 #3 tim.
thel…@[REDACTED] When I try to change the display that is…